Scheduled 3CX Update: Version 20 Update 9 Rollout
Maintenance · identified · started 25 Jun 2026, 22:00
identified · 23 Jun 2026, 15:48
Components: Hosted 3CX Window: 2026-06-25T21:00:00+00:00 → 2026-06-25T22:00:00+00:00 We will be upgrading your hosted 3CX phone system to the latest release, **Version 20 Update 9**, later this week. This keeps your system on the current supported version and adds several improvements. ## What's new - A redesigned Web Client that is cleaner and faster to use - Better call queue handling, including caller callback requests and estimated wait time announcements - Updated AI features, including lower-cost call transcription ## What you need to do - Nothing. The upgrade is applied remotely and your settings carry over automatically. ## What to expect - There may be a short interruption while the upgrade completes - Where possible, avoid time-critical calls during the upgrade window - Most of our systems are already on this version and running normally ## Questions? Contact our support team and we will be happy to help.
identified · 22 Jun 2026, 15:17
Components: Hosted 3CX Window: 2026-06-25T21:00:00+00:00 → 2026-06-25T22:00:00+00:00 We will be upgrading your hosted 3CX phone system to the latest release, **Version 20 Update 9**, later this week. This keeps your system on the current supported version and adds several improvements. ## What's new - A redesigned Web Client that is cleaner and faster to use - Better call queue handling, including caller callback requests and estimated wait time announcements - Updated AI features, including lower-cost call transcription ## What you need to do - Nothing. The upgrade is applied remotely and your settings carry over automatically. ## What to expect - There may be a short interruption while the upgrade completes - Where possible, avoid time-critical calls during the upgrade window - Most of our systems are already on this version and running normally ## Questions? Contact our support team and we will be happy to help.
