Upcoming AWS Maintenance
Maintenance · resolved · started 13 Aug 2026, 04:00 · resolved 13 Aug 2026, 10:00
resolved · 13 Aug 2026, 10:00
Beginning <strong>Wednesday, August 12th, 2026</strong> we'll be performing maintenance on our AWS platform. This maintenance is expected to cause up to <strong>~5 minutes</strong> of downtime.<br/><br/>This maintenance will follow the maintenance windows outlined in our SLA found at https://wpengine.com/legal/sla/.<br/><br/><strong>Data Center location:</strong>	<strong>Maintenance window:</strong><br/>Americas		10PM - 4PM North American Central Time<br/>Europe	4PM - 10PM North American Central Time<br/>Asia-Pacific		8AM - 2PM North American Central Time<br/><br/>If this maintenance will impact your server environment, you will receive an additional follow-up email with confirmation. <br/><br/>Please reach out to our Support team with any questions or concerns, reference maintenance code `awsmaintenance_08122026` and we'll be happy to assist. <br/>
monitoring · 13 Aug 2026, 04:00
Beginning <strong>Wednesday, August 12th, 2026</strong> we'll be performing maintenance on our AWS platform. This maintenance is expected to cause up to <strong>~5 minutes</strong> of downtime.<br/><br/>This maintenance will follow the maintenance windows outlined in our SLA found at https://wpengine.com/legal/sla/.<br/><br/><strong>Data Center location:</strong>	<strong>Maintenance window:</strong><br/>Americas		10PM - 4PM North American Central Time<br/>Europe	4PM - 10PM North American Central Time<br/>Asia-Pacific		8AM - 2PM North American Central Time<br/><br/>If this maintenance will impact your server environment, you will receive an additional follow-up email with confirmation. <br/><br/>Please reach out to our Support team with any questions or concerns, reference maintenance code `awsmaintenance_08122026` and we'll be happy to assist. <br/>
identified · 5 Aug 2026, 19:00
Beginning <strong>Wednesday, August 12th, 2026</strong> we'll be performing maintenance on our AWS platform. This maintenance is expected to cause up to <strong>~5 minutes</strong> of downtime.<br/><br/>This maintenance will follow the maintenance windows outlined in our SLA found at https://wpengine.com/legal/sla/.<br/><br/><strong>Data Center location:</strong>	<strong>Maintenance window:</strong><br/>Americas		10PM - 4PM North American Central Time<br/>Europe	4PM - 10PM North American Central Time<br/>Asia-Pacific		8AM - 2PM North American Central Time<br/><br/>If this maintenance will impact your server environment, you will receive an additional follow-up email with confirmation. <br/><br/>Please reach out to our Support team with any questions or concerns, reference maintenance code `awsmaintenance_08122026` and we'll be happy to assist. <br/>
