DDCMS – Production – (Software Release)
Maintenance · resolved · started 20 Aug 2026, 06:00 · resolved 20 Aug 2026, 07:00
resolved · 20 Aug 2026, 07:00
Dear Customer <br/><br/><strong>In this release</strong><br/>We will be deploying an update to a back-end component of our Direct Debit and Credit Management Service (DDCMS). This update does not change any functionality you use directly.<br/>Please be aware that during this maintenance window, you may experience degraded performance while using DDCMS. This may include slower response times or intermittent delays. We do not anticipate any loss of service, and normal performance is expected to resume once the release has completed.<br/><br/><strong>How we got here</strong><br/>This release has passed its internal Quality Assurance phase and was successfully deployed to our Customer Test environment.<br/><br/><strong>What happens next?</strong><br/>The release will be deployed to our Production environment on the date stated above. Some degradation in performance may be experienced between 06:00 and 07:00 BST while the deployment takes place.<br/>Unless you receive further communication advising otherwise, you can assume the release was deployed successfully in line with the scheduled date and time.<br/><br/><strong>If you need help</strong><br/>To contact our support team, please use the live chat feature within DDCMS, accessible via the chat bubble in the bottom right corner of your screen. Alternatively, you can reach us by phone on 01206 675847 (option 1). Our support team is available Monday to Friday, 8:00am to 5:30pm.<br/><br/>Kind regards<br/>Your Access Team <br/>
monitoring · 20 Aug 2026, 06:00
Dear Customer <br/><br/><strong>In this release</strong><br/>We will be deploying an update to a back-end component of our Direct Debit and Credit Management Service (DDCMS). This update does not change any functionality you use directly.<br/>Please be aware that during this maintenance window, you may experience degraded performance while using DDCMS. This may include slower response times or intermittent delays. We do not anticipate any loss of service, and normal performance is expected to resume once the release has completed.<br/><br/><strong>How we got here</strong><br/>This release has passed its internal Quality Assurance phase and was successfully deployed to our Customer Test environment.<br/><br/><strong>What happens next?</strong><br/>The release will be deployed to our Production environment on the date stated above. Some degradation in performance may be experienced between 06:00 and 07:00 BST while the deployment takes place.<br/>Unless you receive further communication advising otherwise, you can assume the release was deployed successfully in line with the scheduled date and time.<br/><br/><strong>If you need help</strong><br/>To contact our support team, please use the live chat feature within DDCMS, accessible via the chat bubble in the bottom right corner of your screen. Alternatively, you can reach us by phone on 01206 675847 (option 1). Our support team is available Monday to Friday, 8:00am to 5:30pm.<br/><br/>Kind regards<br/>Your Access Team <br/>
identified · 10 Aug 2026, 16:35
Dear Customer <br/><br/><strong>In this release</strong><br/>We will be deploying an update to a back-end component of our Direct Debit and Credit Management Service (DDCMS). This update does not change any functionality you use directly.<br/>Please be aware that during this maintenance window, you may experience degraded performance while using DDCMS. This may include slower response times or intermittent delays. We do not anticipate any loss of service, and normal performance is expected to resume once the release has completed.<br/><br/><strong>How we got here</strong><br/>This release has passed its internal Quality Assurance phase and was successfully deployed to our Customer Test environment.<br/><br/><strong>What happens next?</strong><br/>The release will be deployed to our Production environment on the date stated above. Some degradation in performance may be experienced between 06:00 and 07:00 BST while the deployment takes place.<br/>Unless you receive further communication advising otherwise, you can assume the release was deployed successfully in line with the scheduled date and time.<br/><br/><strong>If you need help</strong><br/>To contact our support team, please use the live chat feature within DDCMS, accessible via the chat bubble in the bottom right corner of your screen. Alternatively, you can reach us by phone on 01206 675847 (option 1). Our support team is available Monday to Friday, 8:00am to 5:30pm.<br/><br/>Kind regards<br/>Your Access Team <br/>
